Increased Streaming Detection Lag and Potential Threat Alert Generation Delay

Incident Report for Obsidian Security

Resolved

This incident has been resolved. Actions to mitigate the conditions resulting in lag on streaming detections within the US environment have been taken and telemetry has confirmed the issue to been fully mitigated.
Posted Jul 18, 2025 - 14:31 PDT

Investigating

Our monitoring has identified an issue within our US environment resulting in increased lag on streaming detections for a subset of customers. While no direct impact has been identified at this time, there is the possibility that alerts resulting from detections designated as streaming might be delayed as time progresses. We will post additional updates as we continue our investigation and mitigation efforts.
Posted Jul 17, 2025 - 12:13 PDT
This incident affected: Threat Management.