Threat alerts and a subset of historical activity not visible within administrator UI

Incident Report for Obsidian Security

Resolved

This incident has been resolved. Fixes addressing UI visibility for threat alerts and historical activity data have each been deployed, and post fix validation confirms each to have been fully mitigated.
Posted Aug 07, 2025 - 09:22 PDT

Update

The scope of impact for this issue has been updated:

A fix for the issue resulting in threat alerts not being visible within the administrator UI threat module has been deployed and verified. During the process of development and deployment, it was additionally found that for a subset for customers within our US environment, a subset of historical activity is not visible within the activity module. The impact of this secondary issue is isolated solely to the ability for the underlying data to be displayed within the UI, with no interruption to threat detections or action policies. A fix for this secondary issue is being prepared and tested, and further updates will be provided once it has been fully deployed and issue mitigation validated.
Posted Aug 06, 2025 - 16:07 PDT

Identified

We have identified the cause of the underlying issue resulting in alerts not being visible within the administrator UI threat module, and are currently implementing a fix. Further updates will be provided once the fix has been fully deployed and issue mitigation validated.
Posted Aug 06, 2025 - 12:53 PDT

Investigating

We are are currently investigating an issue resulting in threat alerts not being visible within the administrator UI threat module. Our teams are actively working to resolve the issue, and we'll provide updates on this incident as they become available.
Posted Aug 06, 2025 - 07:48 PDT
This incident affected: Platform Services (Admin Portal and UI).