Delayed Activity Collection and Threat alerting for Microsoft Connections

Incident Report for Obsidian Security

Resolved

This incident has been resolved. All activity event processing and alerting queues have returned to normalized levels.

If you encounter any further issues, please reach out to our support team.
Posted Jun 03, 2025 - 10:03 PDT

Monitoring

We have identified and resolved an issue that resulted in delayed event population for Microsoft connections between 5/30/2025 4:00 pm PDT and 6/1/2025 9:30 pm PDT. As a result of the delay in event collection, customers may additionally observe a delay in threat alert triggering during the impact window for Microsoft connections.
Posted Jun 02, 2025 - 06:35 PDT
This incident affected: Threat Management.