[Activity] Delay in processing of Activity Data
Incident Report for Obsidian Security
Resolved
All tenants are now fully up to date with the latest Activity Data as of 6 hours ago. Our teams will continue to monitor this from our side, however, this incident is now being marked as resolved.

Please reach out to our support teams in case you have any questions.
Posted Mar 03, 2024 - 08:46 PST
Update
We have made significant progress in reducing the backlog overnight and the delay remains only in a small number of tenants which are recovering at a good pace. We expect the delay to be fully recovered in the next 6-8 hours. We will send an update once the activity data is latest across all tenants.

Please contact our support team in case of any questions.
Posted Mar 02, 2024 - 08:26 PST
Update
Our teams have put measures in place to normalize the infrastructure responsible for processing activity data. We will be monitoring overnight and expect to make significant progress to reduce the overall delay and backlog.

We will share next updates on the overall progress of recovery in the PST morning hours. Please contact our support team in case you have any questions.
Posted Mar 01, 2024 - 18:09 PST
Update
We are aware of a few instances in which some tenants are still seeing delays with Activity data not being the latest. During our efforts to clear the delay in processing the events, we encountered an infrastructure issue which has caused the recovery process to not scale to our expectations. Our teams are continuing to work on optimizing the recovery process to clear the backlog. Next update with more concrete timelines on full recovery will be shared in next 3 hours.

Please contact our support team in case you have any questions.
Posted Mar 01, 2024 - 14:51 PST
Update
We are continuing to monitor this issue on our side. There are still a few tenants where the activity data is not latest and is recovering swiftly. We expect the data to be fully latest by end of today PST. Please contact our support team for any further information that you may require.
Posted Feb 29, 2024 - 13:17 PST
Monitoring
Our systems detected a delay in fetching activity information for connections to Salesforce. Our engineering teams have since identified and resolved the underlying issue and are currently monitoring.

Due to the nature of the fix deployed, it might take a few hours for the data under the 'Activity' section to become latest on our systems for a few tenants. This might also result in some delay in regards to processing of a limited set of Alerts. Please open a support ticket via the normal channels in case more information is required and we would be happy to assist you.
Posted Feb 28, 2024 - 11:44 PST
This incident affected: Threat Management and Platform Services (Connections (SaaS Applications)).