No Routes error message encountered when onboarding oAuth based connections

Incident Report for Obsidian Security

Resolved

This incident has been resolved. We have identified the root cause of the issue resulting in a "No Routes" error being encountered when attempting to onboard oAuth based connections. A fix has now been deployed to all environments, and post fix validation and telemetry have confirmed the issue has been fully mitigated.

If you encounter any further issues, please reach out to our support team.
Posted Jul 08, 2025 - 08:16 PDT

Investigating

We are currently investigating an issue resulting in a "No Routes" error message being encountered when attempting to onboard connections leveraging oAuth authentication. Examples of such connections include Microsoft Graph and Slack. Additional updates will be provided via this posting as our investigation progresses and the issue is mitigated.
Posted Jul 08, 2025 - 07:30 PDT
This incident affected: Platform Services (Connections (SaaS Applications)).