Obsidian Administration UI Access - Cloudflare Outage

Incident Report for Obsidian Security

Resolved

This incident has been resolved. Our monitoring is no longer showing elevated error rates and all components across the Obsidian platform are fully operational.
Posted Dec 05, 2025 - 01:22 PST

Investigating

Obsidian is aware of and tracking the widespread issues with Cloudflare which may be impacting access to the Administration UI. We will post additional updates as we learn of recovery and next steps.
Posted Dec 05, 2025 - 01:07 PST
This incident affected: Platform Services (Admin Portal and UI, Admin Authentication & SSO, Connections (SaaS Applications)).